Results 1 to 4 of 4

Thread: Merkur Progress question, problem.

  1. #1

    Default Merkur Progress question, problem.

    I have a Merkur Progress I bought awhile back, but was wondering, this question I have probably has already been asked before but can't seem to find the thread: when I put a blade in (also without a blade in the razor) and tighten it down all the way close to "1" as it will go, blade gap is fine, head doesn't rock back and forth. As soon as I dial up the razor past about "2", the bottom part of the razor head, (the part that has the triangle engraved on it) rocks back and forth, causing the top part of the razor head plate to have uneven blade gaps from one end of the razor to the other. Basically the razor head assembly doesn't hold firm anymore as soon as you dial up the razor from it's lowest setting. If you push down on the head or lightly press it, one end pops up higher than the other on the razor head. How do you fix this, or is there a way around this problem?

  2. #2
    Join Date
    Nov 2007


    I've had a progress for about 12 years now, and still tightly holds the blade. This sounds like a faulty razor, is it new? merkur may replace it under warranty. It might be worth emailing Mer as I'm sure he'll know if it is repairable. Si

  3. #3


    I too would ask Mer, and I suspect he can point you in the right direction, but it sounds like it's a defect. I would contact the vendor if it's still under warranty.

    If not, I've had a very positive experience with Merkur directly. I had a defect in a razor and they replaced it with a new one gratis. Others have reported less than stellar customer service, but generally Merkur has a very fine reputation for great customer service. PM me for contact information.

  4. #4
    Join Date
    Sep 2007


    If I understand correctly the bottom of the head is rocking on the pedistal connected to the handle. that would be a faulty razor. Mine is securely fastened. replacement or repair is in order. I seem to recall a thread recently where there was a crack that let the razor come apart. perhaps you have a smaller crack starting.


Similar Threads

  1. Merkur Progress assembly problem!
    By ntguy in forum Double Edged Razors
    Replies: 15
    Last Post: 09-08-2010, 06:36 PM
  2. Merkur Progress Problem
    By Flame in forum Double Edged Razors
    Replies: 23
    Last Post: 01-20-2009, 04:03 PM
  3. Merkur Progress Problem
    By billyjeff2 in forum Double Edged Razors
    Replies: 6
    Last Post: 07-16-2007, 10:04 AM
  4. Question on Merkur Progress
    By Boogie in forum Double Edged Razors
    Replies: 3
    Last Post: 05-17-2007, 03:28 PM
  5. Merkur Progress Question
    By Newfie in forum Double Edged Razors
    Replies: 6
    Last Post: 05-02-2007, 11:35 AM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
vBulletin Security provided by vBSecurity (Lite) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd. By accessing Badger & Blade, you agree to abide by the Terms of Usage. You can find our Privacy Policy here.
Once submitted, any posts, images, or content become the property of Badger & Blade.
Powered by vBulletin® - Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.